<!DOCTYPE html>
<html lang="en-US">
<head>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PZQDHVC');</script>
<!-- End Google Tag Manager -->
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://bristolobserver.com/xmlrpc.php" />
	<!--[if IE]><script src="http://bristolobserver.com/wp-content/themes/magazine-basic/library/js/html5.js"></script><![endif]-->
	<title>For Goodness Sake gets help from local Dems &#8211; Bristol Observer</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Bristol Observer &raquo; Feed" href="http://bristolobserver.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bristol Observer &raquo; Comments Feed" href="http://bristolobserver.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bristol Observer &raquo; For Goodness Sake gets help from local Dems Comments Feed" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/bristolobserver.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-polls-css'  href='http://bristolobserver.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://bristolobserver.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Cantata+One|Lato:300,700' type='text/css' media='all' />
<link rel='stylesheet' id='theme_stylesheet-css'  href='http://bristolobserver.com/wp-content/themes/observers-mag-basic/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='font_awesome-css'  href='http://bristolobserver.com/wp-content/themes/magazine-basic/library/css/font-awesome.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://bristolobserver.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.0' type='text/css' media='all' />
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='http://bristolobserver.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://bristolobserver.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://bristolobserver.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Bristol Eastern holds Business Plan Competition' href='http://bristolobserver.com/2017/07/11/bristol-eastern-holds-business-plan-competition/' />
<link rel='next' title='HS students challenged to show how kindness, acceptance can unify communities in contest' href='http://bristolobserver.com/2017/07/11/hs-students-challenged-to-show-how-kindness-acceptance-can-unify-communities-in-contest/' />
<meta name="generator" content="WordPress 4.8" />
<link rel="canonical" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/" />
<link rel='shortlink' href='http://bristolobserver.com/?p=33693' />
<link rel="alternate" type="application/json+oembed" href="http://bristolobserver.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbristolobserver.com%2F2017%2F07%2F11%2Ffor-goodness-sake-gets-help-from-local-dems%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://bristolobserver.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbristolobserver.com%2F2017%2F07%2F11%2Ffor-goodness-sake-gets-help-from-local-dems%2F&#038;format=xml" />
<script src='http://stepsaver.com/?dm=11e3a2debad64faa4cc1356c613ca0f5&action=load&blogid=2&siteid=1&t=1464621360&back=http%3A%2F%2Fbristolobserver.com%2F2017%2F07%2F11%2Ffor-goodness-sake-gets-help-from-local-dems%2F' type='text/javascript'></script><style type='text/css'>img#wpstats{display:none}</style><style>
#site-title a,#site-description{color:#333 !important}
#page{background-color:#ffffff}
.entry-meta a,.entry-content a,.widget a{color:#3D97C2}
</style>
			<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://bristolobserver.com/wp-content/themes/magazine-basic/library/images/solid.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="For Goodness Sake gets help from local Dems" />
<meta property="og:url" content="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/" />
<meta property="og:description" content="Over a dozen members of the Bristol Democratic Town Committee and friends spent a recent Saturday morning at “For Goodness Sake”, the Bristol-based nonprofit at 273 Riverside Avenue that provides h…" />
<meta property="article:published_time" content="2017-07-11T19:55:31+00:00" />
<meta property="article:modified_time" content="2017-07-11T19:55:31+00:00" />
<meta property="og:site_name" content="Bristol Observer" />
<meta property="og:image" content="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2.jpg" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="960" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
// This mapping is for the first ad position
 var mapping0 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([1050, 200], [[970, 90],[728, 90]]). // Desktop
   addSize([980, 690], [[728, 90],[300, 600]]).   //large Tablet
   addSize([320, 700], [[300, 250],[320 , 50]]). // Phone
   addSize([320, 200], [320 , 50]). // Small Phone
  
  build();
 
// This mapping for the 1st rectangle
var mapping1 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([320, 700], [300, 250]). // Tablet
  addSize([1050, 200], [[300, 250], [300, 600]]). // Desktop
  build();

 
// This mapping for the 2nd rectangle
var mapping2 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([320, 700], [300, 250]). // Tablet
  build();

// This mapping for the footer 
var mapping3 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([320, 700], [320, 50]). // Tablet & phones
  addSize([980, 600], [728, 90]). // desktop and large tables
  build();


    googletag.defineSlot('/30582678/RAM/bristolobserver', [[728, 90], [970, 90], [320, 50]], 'div-gpt-ad-1469545119322-0').defineSizeMapping(mapping0).setTargeting("pos", ["atf"]).setCollapseEmptyDiv(true).addService(googletag.pubads());
	    googletag.defineSlot('/30582678/RAM/bristolobserver', [[300, 600],[300, 250] ], 'div-gpt-ad-1469545119322-1').defineSizeMapping(mapping1).setCollapseEmptyDiv(true).setTargeting("pos", ["atf"]).addService(googletag.pubads());
		googletag.defineSlot('/30582678/RAM/bristolobserver', [[300, 250], [300, 600]], 'div-gpt-ad-1469545119322-2').defineSizeMapping(mapping2).setCollapseEmptyDiv(true).addService(googletag.pubads());
		googletag.defineSlot('/30582678/RAM/bristolobserver', [[728, 90], [320, 50]], 'div-gpt-ad-1469545119322-3').defineSizeMapping(mapping3).setCollapseEmptyDiv(true).addService(googletag.pubads());
		 googletag.defineOutOfPageSlot('/30582678/RAM/bristolobserver', 'div-gpt-ad-1470145473303-4').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
</head>

<body class="post-template-default single single-post postid-33693 single-format-video custom-background">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PZQDHVC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div id="page" class="grid  ">
		<header id="header" class="row" role="banner">
			<div class="c12">
				<div id="mobile-menu">
					<a href="#" class="left-menu"><i class="fa fa-reorder"></i></a>
					<a href="#"><i class="fa fa-search"></i></a>
				</div>
				<div id="drop-down-search"><form role="search" method="get" class="search-form" action="http://bristolobserver.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div>

								<div class="title-logo-wrapper fl">
											<a href="http://bristolobserver.com" title="Bristol Observer" id="site-logo"  rel="home"><img src="http://bristolobserver.com/files/2016/11/Bristol-Observer_280w.gif" alt="Bristol Observer" /></a>
										<div class="header-group">
												<div id="site-title" class="remove"><a href="http://bristolobserver.com" title="Bristol Observer" rel="home">Bristol Observer</a></div>
						<div id="site-description">A Stepsaver Publication</div>					</div>
				</div>

									<div id="header-widgets" class="fl">
						<aside id="search-5" class="header-widget widget_search"><h3 class="header-widget-title">Search</h3><form role="search" method="get" class="search-form" action="http://bristolobserver.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>					</div>
					
				<div id="nav-wrapper">
					<div class="nav-content">
						<nav id="site-navigation" class="menus clearfix" role="navigation">
							<h3 class="screen-reader-text">Main menu</h3>
							<a class="screen-reader-text" href="#primary" title="Skip to content">Skip to content</a>
							<div id="main-menu" class="menu-topmenu-container"><ul id="menu-topmenu" class="menu"><li id="menu-item-1941" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children sub-menu-parent menu-item-1941"><a href="http://bristolobserver.com/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-1942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1942"><a href="http://bristolobserver.com/category/news/police/">Police</a>
</ul>

<li id="menu-item-1943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1943"><a href="http://bristolobserver.com/category/sports/">Sports</a>
<li id="menu-item-1944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1944"><a href="http://bristolobserver.com/category/features/">Features</a>
<li id="menu-item-1945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1945"><a href="http://bristolobserver.com/category/features/good-times/">Good Times</a>
<li id="menu-item-1946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1946"><a href="http://bristolobserver.com/category/neighbors/">Neighbors</a>
<li id="menu-item-1947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1947"><a href="http://bristolobserver.com/category/schools/">Schools</a>
<li id="menu-item-23611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23611"><a href="http://bristolobserver.com/category/uncategorized/">Uncategorized</a>
<li id="menu-item-1948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1948"><a href="http://bristolobserver.com/category/listings/">Listings</a>
<li id="menu-item-1950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1950"><a href="http://bristolobserver.com/category/opinion/">Opinion</a>
<li id="menu-item-29991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29991"><a href="http://bristolobserver.com/category/obituaries/obituaries-obituaries/">Obituaries</a>
</ul></div>						</nav><!-- #site-navigation -->

												<nav id="site-sub-navigation" class="menus" role="navigation">
							<h3 class="screen-reader-text">Sub menu</h3>
							<div class="menu-secondmenu-container"><ul id="menu-secondmenu" class="secondary-menu"><li id="menu-item-23013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23013"><a href="http://stepsaver.ct.newsmemory.com/?editionStart=The%20Observer%20Bristol">E-Edition</a>
<li id="menu-item-12929" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12929"><a href="http://bristolobserver.com/about/">Contact Us</a>
<li id="menu-item-12930" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12930"><a href="http://bristolobserver.com/forms/">Forms</a>
<li id="menu-item-12931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12931"><a href="http://bristolobserver.com/subscriptions/">Subscriptions</a>
<li id="menu-item-18584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18584"><a target="_blank" href="https://placeads-dot-rep-am-dot-com.bloxcms.com/place_an_ad_stepsaver/">Place an Ad</a>
</ul></div>						</nav><!-- #site-sub-navigation -->
											</div>
				</div>

			</div><!-- .c12 -->
		</header><!-- #header.row -->

		<div id="main" class="row">
		<div align=center><!-- Top Leaderboard-->
<div id='div-gpt-ad-1469545119322-0' class='ram-leaderboard' role='banner'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-0'); });
</script>
</div></div>
	<div id="primary" class="c6" role="main">
			<article id="post-33693" class="post-33693 post type-post status-publish format-video has-post-thumbnail hentry category-news post_format-post-format-video">
	    <header>
                <div class="post-category"><a href="http://bristolobserver.com/category/news/" rel="category tag">News</a></div>
            <h1 class="entry-title">For Goodness Sake gets help from local Dems</h1>
    <div class="entry-meta">
        <time class="published" datetime="2017-07-11">July 11, 2017</time>&nbsp;&bull;&nbsp;<a href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/#respond">0 Comments</a>    </div>
</header>

		<div class="entry-content">
		    <script type="text/javascript">
(function() {
  var ARTICLE_URL = window.location.href;
  var CONTENT_ID = 'everything';
  document.write(
    '<scr'+'ipt '+
    'src="//survey.g.doubleclick.net/survey?site=_voxu3u2ecxrd4p53djym5ahmiu'+
    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
    '&amp;random='+(new Date).getTime()+
    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
})();
</script><div class="p402_premium"><p>Over a dozen members of the Bristol Democratic Town Committee and friends spent a recent Saturday morning at “For Goodness Sake”, the Bristol-based nonprofit at 273 Riverside Avenue that provides household goods to needy families and individuals who are moving into unfurnished apartments.</p>
<p>The volunteers spent the morning stocking the shelves with recently donated items, helping clients with their selections, and also delivering the items to their homes, said a press release from the Democrats.</p>
<p>The release explained that as the clients (who were screened by local social service partner agencies) started to arrive, small teams of other volunteers followed them around as they filled boxes with selected table settings, cookware, towels, and small appliances. Other volunteers carried sofas, dressers, dining room tables, and other pieces of furniture chosen by the clients out to the loading dock and on into the awaiting delivery van.</p>
<p>The release explained Tina Taylor, assisted by her son Noah, was checking table lamps and vacuum cleaners to make sure they were operational. “This is a great way to spend a few hours, helping others. It’s an amazing organization,” Taylor said, reported the press release. Behind her were sets of bed frames and brand-new mattresses &#8211; state law forbids the sale of used mattresses, so new mattresses are donated by Connecticut Mattress each quarter.</p>
<p>Democrats on hand were Rippy Patton, Kate Matthews, Laura Minor, Craig Minor, Tina Taylor, Greg Hahn, Josh Madeiros, Bryan Dumelin, Ellen Zoppo-Sassu, Sandy Stafford, Karen Vibert, Laura Bartok, Calvin Brown, Brittany Barney, Kim Caron, Debra Schur, and Sue Gorski.</p>
<p>“Since we are 100 percent volunteer driven, we love it when a club or organization like the Bristol Democrats signs up to come in as a group. It’s fun for the members, and we really appreciate the help,” stated Kendra Morales, executive director of the organization, the Democrats’ press release reported.</p>
<p>For Goodness Sake accepts gently used furniture and household goods from the community and distributes them to people in need, serving families and individuals in Bristol, Burlington, Farmington, Harwinton, New Britain, Plainville, Plantsville, Plymouth, Southington, West Hartford, and Wolcott. “For Goodness Sake” clients include victims of domestic violence who are coming out of shelters, people moving into their first apartment from being on the streets, homeless veterans, and people that are homeless and in need of support for a variety of other reasons.</p>
<p>To learn more about how to donate or volunteer at For Goodness Sake, visit their website at <a href="http://www.forgoodnessake.org/">www.forgoodnessake.org</a>.</p>
<div data-carousel-extra='{"blog_id":2,"permalink":"http:\/\/bristolobserver.com\/2017\/07\/11\/for-goodness-sake-gets-help-from-local-dems\/"}' id='gallery-1' class='gallery galleryid-33693 gallery-columns-4 gallery-size-medium'><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-1/'><img width="300" height="225" src="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-300x225.jpg" class="attachment-medium size-medium" alt="" srcset="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-300x225.jpg 300w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-768x576.jpg 768w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-560x420.jpg 560w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-260x195.jpg 260w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-160x120.jpg 160w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1.jpg 960w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="33694" data-permalink="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-1/" data-orig-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1.jpg" data-orig-size="960,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DTC at FGS jul2017 #1" data-image-description="" data-medium-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1-300x225.jpg" data-large-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-1.jpg" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-4/'><img width="243" height="300" src="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-243x300.jpg" class="attachment-medium size-medium" alt="" srcset="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-243x300.jpg 243w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-768x947.jpg 768w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-830x1024.jpg 830w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-560x691.jpg 560w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-260x321.jpg 260w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-160x197.jpg 160w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4.jpg 1152w" sizes="(max-width: 243px) 100vw, 243px" data-attachment-id="33695" data-permalink="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-4/" data-orig-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4.jpg" data-orig-size="1152,1421" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DTC at FGS jul2017 #4" data-image-description="" data-medium-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-243x300.jpg" data-large-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-4-830x1024.jpg" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-3/'><img width="265" height="300" src="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-265x300.jpg" class="attachment-medium size-medium" alt="" srcset="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-265x300.jpg 265w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-768x871.jpg 768w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-903x1024.jpg 903w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-560x635.jpg 560w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-260x295.jpg 260w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-160x181.jpg 160w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id="33696" data-permalink="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-3/" data-orig-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3.jpg" data-orig-size="1806,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DTC at FGS jul2017 #3" data-image-description="" data-medium-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-265x300.jpg" data-large-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-3-903x1024.jpg" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-2/'><img width="225" height="300" src="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2-225x300.jpg" class="attachment-medium size-medium" alt="" srcset="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2-225x300.jpg 225w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2-560x747.jpg 560w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2-260x347.jpg 260w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2-160x213.jpg 160w, http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2.jpg 720w" sizes="(max-width: 225px) 100vw, 225px" data-attachment-id="33697" data-permalink="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/dtc-at-fgs-jul2017-2/" data-orig-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2.jpg" data-orig-size="720,960" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DTC at FGS jul2017 #2" data-image-description="" data-medium-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2-225x300.jpg" data-large-file="http://bristolobserver.com/files/2017/07/DTC-at-FGS-jul2017-2.jpg" /></a>
			</dt></dl><br style="clear: both" />
		</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-33693" class="share-facebook sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-33693" class="share-google-plus-1 sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-33693" class="share-linkedin sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-33693" class="share-twitter sd-button share-icon" href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div></div><script type="text/javascript">try { _402_Show(); } catch(e) {}</script>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>		</div><!-- .entry-content -->

	        <footer class="entry">
	    	</footer><!-- .entry -->
		</article><!-- #post -->
			<div id="posts-pagination">
				<h3 class="screen-reader-text">Post navigation</h3>
				<div class="previous fl"><a href="http://bristolobserver.com/2017/07/11/bristol-eastern-holds-business-plan-competition/" rel="prev">&larr; Bristol Eastern holds Business Plan Competition</a></div>
				<div class="next fr"><a href="http://bristolobserver.com/2017/07/11/hs-students-challenged-to-show-how-kindness-acceptance-can-unify-communities-in-contest/" rel="next">HS students challenged to show how kindness, acceptance can unify communities in contest &rarr;</a></div>
			</div><!-- #posts-pagination -->

			
<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/07/11/for-goodness-sake-gets-help-from-local-dems/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://bristolobserver.com/wp-login.php?redirect_to=http%3A%2F%2Fbristolobserver.com%2F2017%2F07%2F11%2Ffor-goodness-sake-gets-help-from-local-dems%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
			</div><!-- #primary -->

	<div id="secondary" class="c4" role="complementary">
				<aside id="recent-posts-5" class="widget widget_recent_entries">		<h3 class="widget-title">Latest News</h3>		<ul>
					<li>
				<a href="http://bristolobserver.com/2017/07/11/hs-students-challenged-to-show-how-kindness-acceptance-can-unify-communities-in-contest/">HS students challenged to show how kindness, acceptance can unify communities in contest</a>
						</li>
					<li>
				<a href="http://bristolobserver.com/2017/07/11/for-goodness-sake-gets-help-from-local-dems/">For Goodness Sake gets help from local Dems</a>
						</li>
					<li>
				<a href="http://bristolobserver.com/2017/07/11/bristol-eastern-holds-business-plan-competition/">Bristol Eastern holds Business Plan Competition</a>
						</li>
					<li>
				<a href="http://bristolobserver.com/2017/07/11/bristol-man-fined-by-office-of-state-ethics/">Bristol man fined by Office of State Ethics</a>
						</li>
					<li>
				<a href="http://bristolobserver.com/2017/07/11/obituaries-nicolas-b-michaud/">Obituaries: Nicolas B. Michaud</a>
						</li>
				</ul>
		</aside>		<aside id="text-7" class="widget widget_text">			<div class="textwidget"><!-- /30582678/RAM  1st Right Rail-->
<div id='div-gpt-ad-1469545119322-1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-1'); });
</script>
</div>
</div>
		</aside><aside id="classified-search" class="widget widget_class_box"><h3 class="widget-title">Search Classifieds
</h3> <div align=center id=classwidget><form id='classsearch' name='form1' method='post' action='http://stepsaver.com'> 
    <input type='hidden' name='act' value=browse>
    Search For:<br> <input type='text' name='keyword' id='keyword' ='' size='30' /><P>  <select name='section'><option value=''>Select Category</option><option value='TRANSPORTATION'>TRANSPORTATION (7)</option><option value='TAG/ESTATE SALES'>TAG/ESTATE SALES (3)</option><option value='SERVICE DIRECTORY'>SERVICE DIRECTORY (9)</option><option value='RECREATIONAL VEHICLES'>RECREATIONAL VEHICLES (1)</option><option value='REAL ESTATE - SALES'>REAL ESTATE - SALES (3)</option><option value='REAL ESTATE - RENT'>REAL ESTATE - RENT (13)</option><option value='NOTICES'>NOTICES (5)</option><option value='MERCHANDISE'>MERCHANDISE (32)</option><option value='EMPLOYMENT'>EMPLOYMENT (32)</option></select> <P>
       <input name='Search' type='submit' value='Search' class=classbutton />
  
    
    </form></div>
</aside><aside id="text-6" class="widget widget_text">			<div class="textwidget"><div id="repam_container_240">
<script type="text/javascript" src="http://widgets.print2webcorp.com/model/rep-am/featuredads_header_240.js"></script>
<script id="p2w_rep-am-featured-ads" src="http://widgets.print2webcorp.com/widgetcontent/rep-am-featured-ads"></script>
<div class="viewAllAds"><a href="http://www.newspaper-marketplace.com/republican-american" target="_blank">See All Ads</a></div>
<br />
<script type="text/javascript" src="http://widgets.print2webcorp.com/model/rep-am/coupon_header_240.js"></script>
<script id="p2w_rep-am-featured-coupons" src="http://widgets.print2webcorp.com/widgetcontent/rep-am-featured-coupons"></script>
<div class="viewAllAds"><a href="http://www.newspaper-marketplace.com/republican-american" target="_blank">See All Ads</a></div>
</div></div>
		</aside><aside id="text-5" class="widget widget_text"><h3 class="widget-title">Special Sections</h3>			<div class="textwidget"><iframe src="http://widgets.print2webcorp.com/widgetcontent/step-saver-special-sections-ext" width="290px" height="240px" frameborder="0" scrolling="no" style=""></iframe></div>
		</aside><aside id="text-9" class="widget widget_text">			<div class="textwidget"><!-- /30582678/RAM  2nd Right Rail-->
<div id='div-gpt-ad-1469545119322-2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-2'); });
</script>
</div></div>
		</aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><div class="wp_file_get_contents">
<div id="f2f_widget_1285086756"></div>
<script type="text/javascript">
	var f2f = {
	    width: '100%',
	    height: '681',
	    clickTag: '',
	    cacheBuster: ''
	};
	(function() {
	var i = document.createElement('iframe'),
	    w = document.getElementById('f2f_widget_1285086756');
	i.src = 'https://rep-am.friends2follow.com/f2f/widget/async/socialstack/76/0/12/140/1/2/1/0' + 
	'?click=' + (f2f.clickTag.length > 0 ? encodeURIComponent(f2f.clickTag) : '') +
	'&cache=' + (f2f.cacheBuster.length > 0 ? f2f.cacheBuster : ''),
	i.width = f2f.width, i.height = f2f.height, i.scrolling = 'no', i.frameBorder = 0;
	w.appendChild(i);
	})();
</script></div>
</div>
		</aside>	</div><!-- #secondary.widget-area -->

			<div id="tertiary" class="c2 end" role="complementary">
			<aside id="stepsaver-site-list" class="widget widget_list_blogs"><h3 class="widget-title">Stepsaver Sites</h3>
	<ul><li><a href="http://stepsaver.com/"> Stepsaver</a></li><li><a href="http://bristolobserver.com/"> Bristol Observer</a></li><li><a href="http://southingtonobserver.com/"> Southington Observer</a></li><li><a href="http://plainvilleobserver.com/"> Plainville Observer</a></li>	</ul></aside><aside class='widget nlposts-widget'><div class='nlposts-container nlposts-ulist-container nlp-instance-2'><h2 class='nlposts-ulist-wtitle'>Other Observer News</h2><ul class='nlposts-wrapper nlposts-ulist nav nav-tabs nav-stacked'><li class='nlposts-ulist-litem nlposts-siteid-3'><div class='nlposts-caption'><h3 class='nlposts-ulist-title'><a href='http://southingtonobserver.com/2017/07/11/grants-available-for-non-college-bound-students/'>Grants available for non-college-bound students</a></h3></div></li><li class='nlposts-ulist-litem nlposts-siteid-3'><div class='nlposts-caption'><h3 class='nlposts-ulist-title'><a href='http://southingtonobserver.com/2017/07/11/southington-fire-department-encourages-safety-with-summer-fires/'>Southington Fire Department encourages safety with summer fires</a></h3></div></li><li class='nlposts-ulist-litem nlposts-siteid-3'><div class='nlposts-caption'><h3 class='nlposts-ulist-title'><a href='http://southingtonobserver.com/2017/07/10/registration-is-underway-for-the-apple-harvest-road-race/'>Registration is underway for the Apple Harvest Road Race</a></h3></div></li><li class='nlposts-ulist-litem nlposts-siteid-4'><div class='nlposts-caption'><h3 class='nlposts-ulist-title'><a href='http://plainvilleobserver.com/2017/07/11/grants-available-for-non-college-bound-students/'>Grants available for non-college-bound students</a></h3></div></li><li class='nlposts-ulist-litem nlposts-siteid-4'><div class='nlposts-caption'><h3 class='nlposts-ulist-title'><a href='http://plainvilleobserver.com/2017/07/11/democratic-town-committee-meets-july-20/'>Democratic Town Committee meets July 20</a></h3></div></li><li class='nlposts-ulist-litem nlposts-siteid-4'><div class='nlposts-caption'><h3 class='nlposts-ulist-title'><a href='http://plainvilleobserver.com/2017/07/11/petit-martin-host-pizza-and-politics-july-27/'>Petit, Martin host Pizza and Politics, July 27</a></h3></div></li></ul></div></aside><aside id="meta-4" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bristolobserver.com/wp-login.php?action=register">Register</a></li>			<li><a href="http://bristolobserver.com/wp-login.php">Log in</a></li>
			<li><a href="http://bristolobserver.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://bristolobserver.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>		</div><!-- #tertiary.widget-area -->
				<div id="footer-sidebar" class="secondary">
	<div id="footer-sidebar1">
</div>
<div id="footer-sidebar2">
</div>
<div id="footer-sidebar3">
<aside id="meta-5" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bristolobserver.com/wp-login.php?action=register">Register</a></li>			<li><a href="http://bristolobserver.com/wp-login.php">Log in</a></li>
			<li><a href="http://bristolobserver.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://bristolobserver.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside></div>
</div>
	
	</div> <!-- #main.row -->


</div> <!-- #page.grid -->


<footer id="footer" role="contentinfo">

	<div id="footer-content" class="grid ">
	

		<div class="row">
 <center><!--  Footer Ad-->
<div id='div-gpt-ad-1469545119322-3' class='ram-leaderboard' role='banner'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-3'); });
</script>
</div>


<!-- Out of page ad unit -->
<!-- /30582678/RAM/rep-am -->
<div id='div-gpt-ad-1470145473303-4'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1470145473303-4'); });
</script>
</div> </center>



			<p class="copyright c12">
				<span class="fl">Copyright &copy; 2017 <a href="http://bristolobserver.com">Bristol Observer</a>. All Rights Reserved.</span>
				<span class="fr">The Magazine Basic Theme by <a href="https://themes.bavotasan.com/">bavotasan.com</a>.</span>
			</p><!-- .c12 -->

		</div><!-- .row -->

	</div><!-- #footer-content.grid -->

</footer><!-- #footer -->


	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/bristolobserver.com\/2017\/07\/11\/for-goodness-sake-gets-help-from-local-dems\/":33693};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/07/11/for-goodness-sake-gets-help-from-local-dems/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://bristolobserver.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='nlpcss-css'  href='http://bristolobserver.com/wp-content/plugins/network-latest-posts/css/default_style.css?ver=4.8' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://bristolobserver.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201728'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/bristolobserver.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/themes/magazine-basic/library/js/theme.js?ver=4.8'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/bristolobserver.com\/wp-admin\/admin-ajax.php","nonce":"b6d98d0738","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"http:\/\/bristolobserver.com\/wp-login.php?redirect_to=http%3A%2F%2Fbristolobserver.com%2F2017%2F07%2F11%2Ffor-goodness-sake-gets-help-from-local-dems%2F","blog_id":"2","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.0'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201728.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.0',blog:'119882924',post:'33693',tz:'-4',srv:'bristolobserver.com'} ]);
	_stq.push([ 'clickTrackerInit', '119882924', '33693' ]);
</script>
</body>
</html>
<!-- Dynamic page generated in 0.544 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-07-11 21:04:49 -->

<!-- super cache -->