<!DOCTYPE html>
<html lang="en-US">
<head>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PZQDHVC');</script>
<!-- End Google Tag Manager -->
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://bristolobserver.com/xmlrpc.php" />
	<!--[if IE]><script src="http://bristolobserver.com/wp-content/themes/magazine-basic/library/js/html5.js"></script><![endif]-->
	<title>Explosive Lamb of God ignites the crowd&#8217;s excitement &#8211; Bristol Observer</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Bristol Observer &raquo; Feed" href="http://bristolobserver.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bristol Observer &raquo; Comments Feed" href="http://bristolobserver.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bristol Observer &raquo; Explosive Lamb of God ignites the crowd&#8217;s excitement Comments Feed" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/bristolobserver.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-polls-css'  href='http://bristolobserver.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.8' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://bristolobserver.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Cantata+One|Lato:300,700' type='text/css' media='all' />
<link rel='stylesheet' id='theme_stylesheet-css'  href='http://bristolobserver.com/wp-content/themes/observers-mag-basic/style.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='font_awesome-css'  href='http://bristolobserver.com/wp-content/themes/magazine-basic/library/css/font-awesome.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://bristolobserver.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.1.1' type='text/css' media='all' />
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='http://bristolobserver.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://bristolobserver.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://bristolobserver.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Obituaries: Sharlene Davis' href='http://bristolobserver.com/2018/06/05/obituaries-sharlene-davis/' />
<link rel='next' title='Lions announce Soliani Memorial golf tourney' href='http://bristolobserver.com/2018/06/06/lions-announce-soliani-memorial-golf-tourney/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/" />
<link rel='shortlink' href='http://bristolobserver.com/?p=39338' />
<link rel="alternate" type="application/json+oembed" href="http://bristolobserver.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbristolobserver.com%2F2018%2F06%2F06%2Fexplosive-lamb-of-god-ignites-the-crowds-excitement%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://bristolobserver.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbristolobserver.com%2F2018%2F06%2F06%2Fexplosive-lamb-of-god-ignites-the-crowds-excitement%2F&#038;format=xml" />
<script src='http://stepsaver.com/?dm=11e3a2debad64faa4cc1356c613ca0f5&action=load&blogid=2&siteid=1&t=1893501914&back=http%3A%2F%2Fbristolobserver.com%2F2018%2F06%2F06%2Fexplosive-lamb-of-god-ignites-the-crowds-excitement%2F' type='text/javascript'></script><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//bristolobserver.com/?wordfence_lh=1&hid=6F81F31FFC4221B3925B2897AD6750CB');
</script><style type='text/css'>img#wpstats{display:none}</style><style>
#site-title a,#site-description{color:#333 !important}
#page{background-color:#ffffff}
.entry-meta a,.entry-content a,.widget a{color:#3D97C2}
</style>
			<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://bristolobserver.com/wp-content/themes/magazine-basic/library/images/solid.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Explosive Lamb of God ignites the crowd&#8217;s excitement" />
<meta property="og:url" content="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/" />
<meta property="og:description" content="by MIKE CHAIKEN EDITIONS EDITOR The power and fury of Lamb of God was evident two songs into their set at The Dome at Oakdale in Wallingford Sunday, June 3. Prior to Lamb of God’s headlining set, J…" />
<meta property="article:published_time" content="2018-06-06T12:40:57+00:00" />
<meta property="article:modified_time" content="2018-06-06T12:50:22+00:00" />
<meta property="og:site_name" content="Bristol Observer" />
<meta property="og:image" content="http://bristolobserver.com/files/2018/06/LOG_1414.jpg" />
<meta property="og:image:width" content="1958" />
<meta property="og:image:height" content="2048" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Explosive Lamb of God ignites the crowd&#8217;s excitement" />
<meta name="twitter:image" content="http://bristolobserver.com/files/2018/06/LOG_1414.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
// This mapping is for the first ad position
 var mapping0 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([1050, 200], [[970, 90],[728, 90]]). // Desktop
   addSize([980, 690], [[728, 90],[300, 600]]).   //large Tablet
   addSize([320, 700], [[300, 250],[320 , 50]]). // Phone
   addSize([320, 200], [320 , 50]). // Small Phone
  
  build();
 
// This mapping for the 1st rectangle
var mapping1 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([320, 700], [300, 250]). // Tablet
  addSize([1050, 200], [[300, 250], [300, 600]]). // Desktop
  build();

 
// This mapping for the 2nd rectangle
var mapping2 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([320, 700], [300, 250]). // Tablet
  build();

// This mapping for the footer 
var mapping3 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([320, 700], [320, 50]). // Tablet & phones
  addSize([980, 600], [728, 90]). // desktop and large tables
  build();


    googletag.defineSlot('/30582678/RAM/bristolobserver', [[728, 90], [970, 90], [320, 50]], 'div-gpt-ad-1469545119322-0').defineSizeMapping(mapping0).setTargeting("pos", ["atf"]).setCollapseEmptyDiv(true).addService(googletag.pubads());
	    googletag.defineSlot('/30582678/RAM/bristolobserver', [[300, 600],[300, 250] ], 'div-gpt-ad-1469545119322-1').defineSizeMapping(mapping1).setCollapseEmptyDiv(true).setTargeting("pos", ["atf"]).addService(googletag.pubads());
		googletag.defineSlot('/30582678/RAM/bristolobserver', [[300, 250], [300, 600]], 'div-gpt-ad-1469545119322-2').defineSizeMapping(mapping2).setCollapseEmptyDiv(true).addService(googletag.pubads());
		googletag.defineSlot('/30582678/RAM/bristolobserver', [[728, 90], [320, 50]], 'div-gpt-ad-1469545119322-3').defineSizeMapping(mapping3).setCollapseEmptyDiv(true).addService(googletag.pubads());
		 googletag.defineOutOfPageSlot('/30582678/RAM/bristolobserver', 'div-gpt-ad-1470145473303-4').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
</head>

<body class="post-template-default single single-post postid-39338 single-format-video custom-background">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PZQDHVC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div id="page" class="grid  ">
		<header id="header" class="row" role="banner">
			<div class="c12">
				<div id="mobile-menu">
					<a href="#" class="left-menu"><i class="fa fa-reorder"></i></a>
					<a href="#"><i class="fa fa-search"></i></a>
				</div>
				<div id="drop-down-search"><form role="search" method="get" class="search-form" action="http://bristolobserver.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div>

								<div class="title-logo-wrapper fl">
											<a href="http://bristolobserver.com" title="Bristol Observer" id="site-logo"  rel="home"><img src="http://bristolobserver.com/files/2016/11/Bristol-Observer_280w.gif" alt="Bristol Observer" /></a>
										<div class="header-group">
												<div id="site-title" class="remove"><a href="http://bristolobserver.com" title="Bristol Observer" rel="home">Bristol Observer</a></div>
						<div id="site-description">A Stepsaver Publication</div>					</div>
				</div>

									<div id="header-widgets" class="fl">
						<aside id="search-5" class="header-widget widget_search"><h3 class="header-widget-title">Search</h3><form role="search" method="get" class="search-form" action="http://bristolobserver.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>					</div>
					
				<div id="nav-wrapper">
					<div class="nav-content">
						<nav id="site-navigation" class="menus clearfix" role="navigation">
							<h3 class="screen-reader-text">Main menu</h3>
							<a class="screen-reader-text" href="#primary" title="Skip to content">Skip to content</a>
							<div id="main-menu" class="menu-topmenu-container"><ul id="menu-topmenu" class="menu"><li id="menu-item-1941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children sub-menu-parent menu-item-1941"><a href="http://bristolobserver.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-1942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1942"><a href="http://bristolobserver.com/category/news/police/">Police</a>
</ul>

<li id="menu-item-1943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1943"><a href="http://bristolobserver.com/category/sports/">Sports</a>
<li id="menu-item-1944" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1944"><a href="http://bristolobserver.com/category/features/">Features</a>
<li id="menu-item-1945" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1945"><a href="http://bristolobserver.com/category/features/good-times/">Good Times</a>
<li id="menu-item-1946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1946"><a href="http://bristolobserver.com/category/neighbors/">Neighbors</a>
<li id="menu-item-1947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1947"><a href="http://bristolobserver.com/category/schools/">Schools</a>
<li id="menu-item-23611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23611"><a href="http://bristolobserver.com/category/uncategorized/">Uncategorized</a>
<li id="menu-item-1948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1948"><a href="http://bristolobserver.com/category/listings/">Listings</a>
<li id="menu-item-1950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1950"><a href="http://bristolobserver.com/category/opinion/">Opinion</a>
<li id="menu-item-29991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29991"><a href="http://bristolobserver.com/category/obituaries/obituaries-obituaries/">Obituaries</a>
</ul></div>						</nav><!-- #site-navigation -->

												<nav id="site-sub-navigation" class="menus" role="navigation">
							<h3 class="screen-reader-text">Sub menu</h3>
							<div class="menu-secondmenu-container"><ul id="menu-secondmenu" class="secondary-menu"><li id="menu-item-23013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23013"><a href="http://stepsaver.ct.newsmemory.com/?editionStart=The%20Observer%20Bristol">E-Edition</a>
<li id="menu-item-12929" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12929"><a href="http://bristolobserver.com/about/">Contact Us</a>
<li id="menu-item-12930" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12930"><a href="http://bristolobserver.com/forms/">Forms</a>
<li id="menu-item-12931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12931"><a href="http://bristolobserver.com/subscriptions/">Subscriptions</a>
<li id="menu-item-18584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18584"><a target="_blank" href="https://placeads-dot-rep-am-dot-com.bloxcms.com/place_an_ad_stepsaver/">Place an Ad</a>
<li id="menu-item-35008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35008"><a href="http://stepsaver.com/employment/">Employment</a>
</ul></div>						</nav><!-- #site-sub-navigation -->
											</div>
				</div>

			</div><!-- .c12 -->
		</header><!-- #header.row -->

		<div id="main" class="row">
		<div align=center><!-- Top Leaderboard-->
<div id='div-gpt-ad-1469545119322-0' class='ram-leaderboard' role='banner'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-0'); });
</script>
</div></div>
	<div id="primary" class="c8" role="main">
			<article id="post-39338" class="post-39338 post type-post status-publish format-video has-post-thumbnail hentry category-features category-good-times tag-behemoth tag-jasta tag-lamb-of-god tag-review post_format-post-format-video">
	    <header>
                <div class="post-category"><a href="http://bristolobserver.com/category/features/" rel="category tag">Features</a>, <a href="http://bristolobserver.com/category/features/good-times/" rel="category tag">Good Times</a></div>
            <h1 class="entry-title">Explosive Lamb of God ignites the crowd&#8217;s excitement</h1>
    <div class="entry-meta">
        <time class="published" datetime="2018-06-06">June 6, 2018</time>&nbsp;&bull;&nbsp;<a href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/#respond">0 Comments</a>    </div>
</header>

		<div class="entry-content">
		    <script type="text/javascript">
(function() {
  var ARTICLE_URL = window.location.href;
  var CONTENT_ID = 'everything';
  document.write(
    '<scr'+'ipt '+
    'src="//survey.g.doubleclick.net/survey?site=_voxu3u2ecxrd4p53djym5ahmiu'+
    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
    '&amp;random='+(new Date).getTime()+
    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
})();
</script><div class="p402_premium"><p><span style="font-family: Calibri">by MIKE CHAIKEN</span></p>
<p><span style="font-family: Calibri">EDITIONS EDITOR</span></p>
<p><span style="font-family: Calibri">The power and fury of Lamb of God was evident two songs into their set at The Dome at Oakdale in Wallingford Sunday, June 3.</span></p>
<p><span style="font-family: Calibri">Prior to Lamb of God’s headlining set, Jasta and Behemoth set the heavy metal table.</span></p>
<p><span style="color: #000000;font-family: Calibri">As both bands whipped through their sets, the audience was enraptured and hypnotized by the action on stage.</span></p>
<p><span style="color: #000000;font-family: Calibri">Jasta, a local favorite because it’s a spin off of Connecticut’s own Hatebreed, played its own brand of heavy metal filled with tight grooves and a grass roots vibe. Lead singer Jamey Jasta clearly enjoyed the opportunity to play to tightly packed crowd under The Dome at Xfinity Theater. He relished his role to establish the communal atmosphere of a metal show.</span></p>
<p><span style="color: #000000;font-family: Calibri">Behemoth, who has been touring with Slayer as has Lamb of God been, carried the torch of mysterious, magical, mythical and epic metal. With their monkish hoods and makeup, they looked and played like demonic gods from medieval mythologies. They were larger than life and their set was hypnotizing.</span></p><div class="WkisDkm3" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><div class="stanzacal" data-width="100%" data-height="250px" ></div> <script src="https://dff2h0hbfv6w4.cloudfront.net/scripts/embed-stanzacal-v1.js" type="text/javascript"></script></div>
<p><span style="color: #000000;font-family: Calibri">But Lamb of God, playing in a rare smaller venue, upped the energy level to 11 in the building.</span></p>
<p><span style="color: #000000;font-family: Calibri">Lamb of God, touring behind “Legion: XX,” an album of punk rock covers under the original name Burn the Priest, took no time at all to set a fire underneath the crowd’s collective feet.</span></p>
<p><span style="color: #000000;font-family: Calibri">During Behemoth and Jasta, there were a few isolated incidents of crowd surfing that put security on alert. But they clearly were part of the metal ritual.</span></p>
<p><span style="color: #000000;font-family: Calibri">And as Lamb of God ripped into “Omerta” upon their stage entrance, the crowd was still grounded&#8211; albeit more enthusiastic and stoked than they were during the openers.</span></p>
<p><span style="color: #000000;font-family: Calibri">But as soon as the first notes of “Ruin” sounded, the energy level in the crowd exploded and had nowhere to go but up.</span></p>
<p><span style="color: #000000;font-family: Calibri">And soon, security took formation as fan after fan bombarded the stage as they soared across the hands and arms of their fan-mates.</span></p>
<p><span style="color: #000000;font-family: Calibri">All the commotion was understandable as Lamb of God lead singer Randy Blythe was primal and powerful as they launched into his vocals. And the band as a whole marched forward as a tightly primed metal machine—musically taut and tight and intent on a metallic groove.</span></p>
<p><span style="color: #000000;font-family: Calibri">Lamb of God clearly must feel blessed to be part of Slayer’s farewell tour, which set down at the Mohegan Sun in Uncasville two nights before.</span></p>
<p><span style="color: #000000;font-family: Calibri">But Lamb of God proved their true element is under the spotlight where they not only provide the fuel for the fire in the ardor of metal fans, they are also the match that ignites the bomb of the fans’ adulation.</span></p>
<p>PHOTOS by MIKE CHAIKEN</p>
<div data-carousel-extra='{"blog_id":2,"permalink":"http:\/\/bristolobserver.com\/2018\/06\/06\/explosive-lamb-of-god-ignites-the-crowds-excitement\/"}' id='gallery-1' class='gallery galleryid-39338 gallery-columns-5 gallery-size-thumbnail'><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1545/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1545-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39336" data-attachment-id="39336" data-permalink="http://bristolobserver.com/log_1545/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1545.jpg" data-orig-size="1905,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1545" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1545-279x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1545-953x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39336'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1515/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1515-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39335" data-attachment-id="39335" data-permalink="http://bristolobserver.com/log_1515/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1515.jpg" data-orig-size="1592,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1515" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1515-233x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1515-796x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39335'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1509/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1509-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39334" data-attachment-id="39334" data-permalink="http://bristolobserver.com/log_1509/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1509.jpg" data-orig-size="1289,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1509" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1509-189x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1509-645x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39334'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1491/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1491-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39333" data-attachment-id="39333" data-permalink="http://bristolobserver.com/log_1491/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1491.jpg" data-orig-size="944,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1491" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1491-138x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1491-472x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39333'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1481/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1481-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39332" data-attachment-id="39332" data-permalink="http://bristolobserver.com/log_1481/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1481.jpg" data-orig-size="1233,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1481" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1481-181x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1481-617x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39332'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/log_1477/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1477-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39331" data-attachment-id="39331" data-permalink="http://bristolobserver.com/log_1477/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1477.jpg" data-orig-size="2048,1777" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1477" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1477-300x260.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1477-1024x889.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39331'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1419/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1419-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39330" data-attachment-id="39330" data-permalink="http://bristolobserver.com/log_1419/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1419.jpg" data-orig-size="1292,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1419" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1419-189x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1419-646x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39330'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1418/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1418-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39329" srcset="http://bristolobserver.com/files/2018/06/LOG_1418-150x150.jpg 150w, http://bristolobserver.com/files/2018/06/LOG_1418-298x300.jpg 298w, http://bristolobserver.com/files/2018/06/LOG_1418-768x773.jpg 768w, http://bristolobserver.com/files/2018/06/LOG_1418-1017x1024.jpg 1017w, http://bristolobserver.com/files/2018/06/LOG_1418-560x564.jpg 560w, http://bristolobserver.com/files/2018/06/LOG_1418-260x262.jpg 260w, http://bristolobserver.com/files/2018/06/LOG_1418-160x161.jpg 160w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="39329" data-permalink="http://bristolobserver.com/log_1418/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1418.jpg" data-orig-size="2034,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1418" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1418-298x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1418-1017x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39329'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1414/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1414-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39328" data-attachment-id="39328" data-permalink="http://bristolobserver.com/log_1414/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1414.jpg" data-orig-size="1958,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1414" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1414-287x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1414-979x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39328'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1401/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1401-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39327" data-attachment-id="39327" data-permalink="http://bristolobserver.com/log_1401/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1401.jpg" data-orig-size="1648,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1401" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1401-241x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1401-824x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39327'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/log_1371/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/LOG_1371-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39326" data-attachment-id="39326" data-permalink="http://bristolobserver.com/log_1371/" data-orig-file="http://bristolobserver.com/files/2018/06/LOG_1371.jpg" data-orig-size="1420,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOG_1371" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/LOG_1371-208x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/LOG_1371-710x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39326'>
				Lamb of God at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_1332/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1332-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39325" data-attachment-id="39325" data-permalink="http://bristolobserver.com/beh_1332/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1332.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1332" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1332-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1332-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39325'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_1309/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1309-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39324" data-attachment-id="39324" data-permalink="http://bristolobserver.com/beh_1309/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1309.jpg" data-orig-size="1502,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1309" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1309-220x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1309-751x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39324'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_1282/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1282-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39323" data-attachment-id="39323" data-permalink="http://bristolobserver.com/beh_1282/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1282.jpg" data-orig-size="1269,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1282" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1282-186x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1282-635x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39323'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/beh_1243/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1243-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39322" data-attachment-id="39322" data-permalink="http://bristolobserver.com/beh_1243/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1243.jpg" data-orig-size="2048,1487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1243" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1243-300x218.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1243-1024x744.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39322'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/beh_1220/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1220-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39321" data-attachment-id="39321" data-permalink="http://bristolobserver.com/beh_1220/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1220.jpg" data-orig-size="2048,1381" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1220" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1220-300x202.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1220-1024x691.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39321'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/beh_1203/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1203-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39320" data-attachment-id="39320" data-permalink="http://bristolobserver.com/beh_1203/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1203.jpg" data-orig-size="2048,1710" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1203" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1203-300x250.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1203-1024x855.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39320'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_1104/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1104-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39319" data-attachment-id="39319" data-permalink="http://bristolobserver.com/beh_1104/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1104.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1104" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1104-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1104-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39319'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_1094/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1094-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39318" data-attachment-id="39318" data-permalink="http://bristolobserver.com/beh_1094/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1094.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1094" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1094-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1094-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39318'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_1070/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_1070-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39317" data-attachment-id="39317" data-permalink="http://bristolobserver.com/beh_1070/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_1070.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_1070" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_1070-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_1070-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39317'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/beh_0987/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/BEH_0987-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39316" data-attachment-id="39316" data-permalink="http://bristolobserver.com/beh_0987/" data-orig-file="http://bristolobserver.com/files/2018/06/BEH_0987.jpg" data-orig-size="1460,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BEH_0987" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/BEH_0987-214x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/BEH_0987-730x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39316'>
				Behemoth at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/mem_0968/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0968-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39315" data-attachment-id="39315" data-permalink="http://bristolobserver.com/mem_0968/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0968.jpg" data-orig-size="2048,1687" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0968" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0968-300x247.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0968-1024x844.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39315'>
				Howard Jones, formerly of Killswitch Engage, joins Jasta for a song at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/mem_0904/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0904-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39314" data-attachment-id="39314" data-permalink="http://bristolobserver.com/mem_0904/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0904.jpg" data-orig-size="2048,1363" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0904" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0904-300x200.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0904-1024x682.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39314'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/mem_0691/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0691-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39313" data-attachment-id="39313" data-permalink="http://bristolobserver.com/mem_0691/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0691.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0691" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0691-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0691-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39313'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/mem_0639/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0639-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39312" data-attachment-id="39312" data-permalink="http://bristolobserver.com/mem_0639/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0639.jpg" data-orig-size="2048,1700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0639" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0639-300x249.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0639-1024x850.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39312'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/mem_0591/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0591-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39311" data-attachment-id="39311" data-permalink="http://bristolobserver.com/mem_0591/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0591.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0591" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0591-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0591-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39311'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/mem_0566/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0566-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39310" data-attachment-id="39310" data-permalink="http://bristolobserver.com/mem_0566/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0566.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0566" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0566-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0566-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39310'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='http://bristolobserver.com/mem_0545/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0545-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39309" data-attachment-id="39309" data-permalink="http://bristolobserver.com/mem_0545/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0545.jpg" data-orig-size="2048,1868" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0545" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0545-300x274.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0545-1024x934.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39309'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/mem_0491/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0491-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39308" data-attachment-id="39308" data-permalink="http://bristolobserver.com/mem_0491/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0491.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0491" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0491-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0491-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39308'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/mem_0477/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0477-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39307" data-attachment-id="39307" data-permalink="http://bristolobserver.com/mem_0477/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0477.jpg" data-orig-size="1741,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0477" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0477-255x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0477-871x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39307'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='http://bristolobserver.com/mem_0422/'><img width="150" height="150" src="http://bristolobserver.com/files/2018/06/MEM_0422-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" aria-describedby="gallery-1-39306" data-attachment-id="39306" data-permalink="http://bristolobserver.com/mem_0422/" data-orig-file="http://bristolobserver.com/files/2018/06/MEM_0422.jpg" data-orig-size="1367,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MEM_0422" data-image-description="" data-medium-file="http://bristolobserver.com/files/2018/06/MEM_0422-200x300.jpg" data-large-file="http://bristolobserver.com/files/2018/06/MEM_0422-684x1024.jpg" /></a>
			</dt>
				<dd class='wp-caption-text gallery-caption' id='gallery-1-39306'>
				Jasta at The Dome at Oakdale June 3.
				</dd></dl>
			<br style='clear: both' />
		</div>

</p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-39338" class="share-facebook sd-button share-icon" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-39338" class="share-google-plus-1 sd-button share-icon" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-39338" class="share-linkedin sd-button share-icon" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-39338" class="share-twitter sd-button share-icon" href="http://bristolobserver.com/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div></div><script type="text/javascript">try { _402_Show(); } catch(e) {}</script>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>		</div><!-- .entry-content -->

	        <footer class="entry">
	    <p class="tags">Tags: <a href="http://bristolobserver.com/tag/behemoth/" rel="tag">Behemoth</a> <a href="http://bristolobserver.com/tag/jasta/" rel="tag">Jasta</a> <a href="http://bristolobserver.com/tag/lamb-of-god/" rel="tag">Lamb of God</a> <a href="http://bristolobserver.com/tag/review/" rel="tag">review</a></p>	</footer><!-- .entry -->
		</article><!-- #post -->
			<div id="posts-pagination">
				<h3 class="screen-reader-text">Post navigation</h3>
				<div class="previous fl"><a href="http://bristolobserver.com/2018/06/05/obituaries-sharlene-davis/" rel="prev">&larr; Obituaries: Sharlene Davis</a></div>
				<div class="next fr"><a href="http://bristolobserver.com/2018/06/06/lions-announce-soliani-memorial-golf-tourney/" rel="next">Lions announce Soliani Memorial golf tourney &rarr;</a></div>
			</div><!-- #posts-pagination -->

			
<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/06/06/explosive-lamb-of-god-ignites-the-crowds-excitement/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://bristolobserver.com/wp-login.php?redirect_to=http%3A%2F%2Fbristolobserver.com%2F2018%2F06%2F06%2Fexplosive-lamb-of-god-ignites-the-crowds-excitement%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
			</div><!-- #primary -->

	<div id="secondary" class="c4 end" role="complementary">
				<aside id="recent-posts-5" class="widget widget_recent_entries">		<h3 class="widget-title">Latest News</h3>		<ul>
											<li>
					<a href="http://bristolobserver.com/2018/06/06/obituaries-vito-masotti/">Obituaries: Vito Masotti</a>
									</li>
											<li>
					<a href="http://bristolobserver.com/2018/06/06/three-injured-in-two-car-accident-tuesday/">Three injured in two-car accident Tuesday</a>
									</li>
											<li>
					<a href="http://bristolobserver.com/2018/06/06/blues-launch-season-with-3-1-victory/">Blues launch season with 3-1 victory</a>
									</li>
											<li>
					<a href="http://bristolobserver.com/2018/06/06/kids-listing-starting-june-8/">Kids listing starting June 8</a>
									</li>
											<li>
					<a href="http://bristolobserver.com/2018/06/06/health-listings-starting-june-8/">Health listings starting June 8</a>
									</li>
					</ul>
		</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /30582678/RAM  1st Right Rail-->
<div id='div-gpt-ad-1469545119322-1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-1'); });
</script>
</div>
</div></aside><aside id="widget_sp_image-3" class="widget widget_sp_image"><h3 class="widget-title">Readers Choice</h3><a href="http://bristolobserver.com/readers-choice/" target="_self" class="widget_sp_image-image-link" title="Readers Choice"><img width="1651" height="1275" alt="Readers Choice" class="attachment-full" style="max-width: 100%;" srcset="http://bristolobserver.com/files/2018/05/SS-rc-logo.jpg 1651w, http://bristolobserver.com/files/2018/05/SS-rc-logo-300x232.jpg 300w, http://bristolobserver.com/files/2018/05/SS-rc-logo-768x593.jpg 768w, http://bristolobserver.com/files/2018/05/SS-rc-logo-1024x791.jpg 1024w, http://bristolobserver.com/files/2018/05/SS-rc-logo-560x432.jpg 560w, http://bristolobserver.com/files/2018/05/SS-rc-logo-260x201.jpg 260w, http://bristolobserver.com/files/2018/05/SS-rc-logo-160x124.jpg 160w" sizes="(max-width: 1651px) 100vw, 1651px" src="http://bristolobserver.com/files/2018/05/SS-rc-logo.jpg" /></a></aside><aside id="classified-search" class="widget widget_class_box"><h3 class="widget-title">Search Classifieds
</h3> <div align=center id=classwidget><form id='classsearch' name='form1' method='post' action='http://stepsaver.com'> 
    <input type='hidden' name='act' value=browse>
    Search For:<br> <input type='text' name='keyword' id='keyword' ='' size='30' /><P>  <select name='section'><option value=''>Select Category</option><option value='TRANSPORTATION'>TRANSPORTATION (7)</option><option value='TAG/ESTATE SALES'>TAG/ESTATE SALES (14)</option><option value='SERVICE DIRECTORY'>SERVICE DIRECTORY (13)</option><option value='RECREATIONAL VEHICLES'>RECREATIONAL VEHICLES (3)</option><option value='REAL ESTATE - SALES'>REAL ESTATE - SALES (4)</option><option value='REAL ESTATE - RENT'>REAL ESTATE - RENT (14)</option><option value='NOTICES'>NOTICES (3)</option><option value='MERCHANDISE'>MERCHANDISE (17)</option><option value='EMPLOYMENT'>EMPLOYMENT (32)</option></select> <P>
       <input name='Search' type='submit' value='Search' class=classbutton />
  
    
    </form></div>
</aside><aside id="polls-widget-4" class="widget widget_polls-widget"><h3 class="widget-title">Polls</h3>Sorry, there are no polls available at the moment.<ul><li><a href="http://bristolobserver.stepsaver.com/pollsarchive">Polls Archive</a></li></ul></aside><aside id="text-6" class="widget widget_text">			<div class="textwidget"><div id="repam_container_240">
<script type="text/javascript" src="http://widgets.print2webcorp.com/model/rep-am/featuredads_header_240.js"></script>
<script id="p2w_rep-am-featured-ads" src="http://widgets.print2webcorp.com/widgetcontent/rep-am-featured-ads"></script>
<div class="viewAllAds"><a href="http://www.newspaper-marketplace.com/republican-american" target="_blank">See All Ads</a></div>
<br />
<script type="text/javascript" src="http://widgets.print2webcorp.com/model/rep-am/coupon_header_240.js"></script>
<script id="p2w_rep-am-featured-coupons" src="http://widgets.print2webcorp.com/widgetcontent/rep-am-featured-coupons"></script>
<div class="viewAllAds"><a href="http://www.newspaper-marketplace.com/republican-american" target="_blank">See All Ads</a></div>
</div></div>
		</aside><aside id="text-5" class="widget widget_text"><h3 class="widget-title">Special Sections</h3>			<div class="textwidget"><iframe src="http://widgets.print2webcorp.com/widgetcontent/step-saver-special-sections-ext" width="290px" height="240px" frameborder="0" scrolling="no" style=""></iframe></div>
		</aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /30582678/RAM  2nd Right Rail-->
<div id='div-gpt-ad-1469545119322-2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-2'); });
</script>
</div></div></aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><div class="wp_file_get_contents">
<div id="f2f_widget_1285086756"></div>
<script type="text/javascript">
	var f2f = {
	    width: '100%',
	    height: '681',
	    clickTag: '',
	    cacheBuster: ''
	};
	(function() {
	var i = document.createElement('iframe'),
	    w = document.getElementById('f2f_widget_1285086756');
	i.src = 'https://rep-am.friends2follow.com/f2f/widget/async/socialstack/76/0/12/140/1/2/1/0' + 
	'?click=' + (f2f.clickTag.length > 0 ? encodeURIComponent(f2f.clickTag) : '') +
	'&cache=' + (f2f.cacheBuster.length > 0 ? f2f.cacheBuster : ''),
	i.width = f2f.width, i.height = f2f.height, i.scrolling = 'no', i.frameBorder = 0;
	w.appendChild(i);
	})();
</script></div><!-- .wp_file_get_contents -->
</div>
		</aside><aside id="meta-6" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bristolobserver.com/wp-login.php?action=register">Register</a></li>			<li><a href="http://bristolobserver.com/wp-login.php">Log in</a></li>
			<li><a href="http://bristolobserver.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://bristolobserver.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>	</div><!-- #secondary.widget-area -->

			<div id="footer-sidebar" class="secondary">
	<div id="footer-sidebar1">
<aside id="stepsaver-site-list" class="widget widget_list_blogs"><h3 class="widget-title">Stepsaver Sites</h3>
	<ul><li><a href="http://stepsaver.com/"> Stepsaver</a></li><li><a href="http://bristolobserver.com/"> Bristol Observer</a></li><li><a href="http://southingtonobserver.com/"> Southington Observer</a></li><li><a href="http://plainvilleobserver.com/"> Plainville Observer</a></li>	</ul></aside></div>
<div id="footer-sidebar2">
<aside id="meta-4" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bristolobserver.com/wp-login.php?action=register">Register</a></li>			<li><a href="http://bristolobserver.com/wp-login.php">Log in</a></li>
			<li><a href="http://bristolobserver.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://bristolobserver.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside></div>
<div id="footer-sidebar3">
<aside id="meta-5" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bristolobserver.com/wp-login.php?action=register">Register</a></li>			<li><a href="http://bristolobserver.com/wp-login.php">Log in</a></li>
			<li><a href="http://bristolobserver.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://bristolobserver.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside></div>
</div>
	
	</div> <!-- #main.row -->


</div> <!-- #page.grid -->


<footer id="footer" role="contentinfo">

	<div id="footer-content" class="grid ">
	

		<div class="row">
 <center><!--  Footer Ad-->
<div id='div-gpt-ad-1469545119322-3' class='ram-leaderboard' role='banner'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469545119322-3'); });
</script>
</div>


<!-- Out of page ad unit -->
<!-- /30582678/RAM/rep-am -->
<div id='div-gpt-ad-1470145473303-4'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1470145473303-4'); });
</script>
</div> </center>



			<p class="copyright c12">
				<span class="fl">Copyright &copy; 2018 <a href="http://bristolobserver.com">Bristol Observer</a>. All Rights Reserved.</span>
				<span class="fr">The Magazine Basic Theme by <a href="https://themes.bavotasan.com/">bavotasan.com</a>.</span>
			</p><!-- .c12 -->

		</div><!-- .row -->

	</div><!-- #footer-content.grid -->

</footer><!-- #footer -->


	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/bristolobserver.com\/2018\/06\/06\/explosive-lamb-of-god-ignites-the-crowds-excitement\/":39338};
	</script>
<link rel='stylesheet' id='nlpcss-css'  href='http://bristolobserver.com/wp-content/plugins/network-latest-posts/css/default_style.css?ver=4.9.6' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://bristolobserver.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201823'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/bristolobserver.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.8'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/comment-reply.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/themes/magazine-basic/library/js/theme.js?ver=4.9.6'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/bristolobserver.com\/wp-admin\/admin-ajax.php","nonce":"ee9df3dea3","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"http:\/\/bristolobserver.com\/wp-login.php?redirect_to=http%3A%2F%2Fbristolobserver.com%2F2018%2F06%2F06%2Fexplosive-lamb-of-god-ignites-the-crowds-excitement%2F","blog_id":"2","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://bristolobserver.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.1.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201823.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1.1',blog:'119882924',post:'39338',tz:'-4',srv:'bristolobserver.com'} ]);
	_stq.push([ 'clickTrackerInit', '119882924', '39338' ]);
</script>
</body>
</html>